Fonksiyonlar » Mantıksal Fonksiyonlar

DIR Fonksiyonları

DIR işlevleri olarak anılan bu işlevlerin her biri, belirtilen değeri denetler ve sonuca göre DOĞRU ya da YANLIŞ değeri verir. Örneğin, ISBLANK (EBOŞSA) fonksiyonu boş bir hücreye referans edilirse DOĞRU mantıksal değerini verir; aksi koşullarda verdiği değer YANLIŞ olacaktır.

Bir değerin üzerinde hesaplama veya başka eylemler yapmadan önce değer hakkında bilgi edinmek için DIR işlevlerinden birini kullanmak faydalı olacaktır. Örneğin, hata oluştuğunda farklı bir eylem gerçekleştirmek için IFERROR (EHATALIYSA) işlevini IF (EĞER) işlevi ile birlikte kullanılabilir.

 

Kullanılış Şekli :

=EĞER(EHATALIYSA(A1), "Hata oluştu.", A1 * 2)

=IF(ISERROR(A1), "Hata oluştu.", A1 * 2)

Bu formül A1'de bir hata durumu olup olmadığını denetler. Varsa, EĞER işlevi "Hata oluştu." iletisini verir. Hata yoksa, EĞER işlevi A1*2 hesaplamasını yapar.

 

 

 

 

Kullanıma Örnek :


Yukarıdaki örnek uygulamanın excel versiyonunu buradan indirebilirsiniz...


  • Lookup Formülleri

    Excel'de sıklıkla kullanılan Lookup formülleri ile ilgili örnekli anlatımlara ulaşmak için tıklayınız.

    Devamı »

  • Excel İpuçları

    Zaman kazandıracak faydalı ipuçları ve daha fazlası için mutlaka göz atın.              

    Devamı »

  • VBA Programlama

    VBA makroları oluşturarak Excel'in sınırlarını zorlayın. Örnek kodları inceleyin veya kendi makronuzu kaydedin.

    Devamı »